Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google      Sign In   
  • Create Account

Subscribe to HRA Now!

 



Are you a Google Analytics enthusiast?

Share and download Custom Google Analytics Reports, dashboards and advanced segments--for FREE! 

 



 

 www.CustomReportSharing.com 

From the folks who brought you High Rankings!



Photo

Can You Help Decipher This Error Message In G. Analytics ?


Best Answer torka , 12 February 2013 - 11:06 AM

When you set up the account all those years ago, you specified domain.com  as your website address. Since then, you've apparently decided to use www.domain.com and have set up everything else to point to the "www" version. However, your site profile in Analytics still points to the "non-www" version.

 

Log in to Analytics. Click the "Admin" button near the top, on the right. The screen will display a list of accounts (you will probably only have one). Click the name of that account to select it.

 

The screen will display a list of properties (websites) associated with that account (if you only have one website, there may only be that one listed; if you set up more than one website in Analytics, you may have more than one property included in that account). Click the name of the property that's causing the error message to select it.

 

The screen will display a list of all the profiles you've set up that are associated with that property. It's likely there will only be one. Click on that profile to select it.

 

The screen will display the settings for that profile. Click the tab for "Profile Settings". You will see on that tab that the site has been set up for domain.com. Change that to www.domain.com to match what you've set up everywhere else. Make sure your time zone is correct, and if you've specified a default page make sure that is still the correct page name (i.e. "index.html" or "default.asp" or "home.php" or whatever). Click the "Apply" button at the bottom of the page.

 

I honestly don't know how long it will take, but I'm guessing you will probably have to wait until the following calendar day until you see the change fully in effect.

 

If you still need more info, try the Google Analytics Help. (Click the "Help" button right next to the "Admin" button on the orange toolbar at the top.)

 

Hope this helps! :)

 

--Torka :propeller:

Go to the full post


  • Please log in to reply
3 replies to this topic

#1 kslnor

kslnor

    HR 2

  • Members
  • PipPip
  • 40 posts
  • Location:USA

Posted 11 February 2013 - 10:41 AM

While going through Google Analytics for my site, I received this error message when I checked the In-Page Analytics section (located in the content section):

 

 

Problem loading In-Page Analytics
We've identified problems in your setup. These may cause problems loading In-Page Analytics.

 

Error: The Website in your settings (http://mydomain.com),
redirects into a different domain. (http://www.mydomain.com).
In-Page Analytics currently works on only one domain.
Note that www.example.com and example.com are NOT considered to be on the same domain.
Also, make sure you're not redirecting from http:// to https:// or vice versa.

 

 

A few months ago I did the following:

1) I switched my site from a plain 'ole static site to a blog

2) 301 redirected from non-www to www.

3) set preferred domain in G. Webmaster Tools www.mydomain.com

4) the canonical domain via source code of site is www.mydomain.com

 

I'm not sure what to do / if I need to fix this / if this causes a dup. content issue.  I set up analytics several years ago, but I don't remember the specifics.

 

Any help / guidance appreciated.

 

Thanks !

 

 



#2 torka

torka

    Vintage Babe

  • Moderator
  • 4,585 posts
  • Location:Triangle area, NC, USA, Earth (usually)

Posted 12 February 2013 - 11:06 AM   Best Answer

When you set up the account all those years ago, you specified domain.com  as your website address. Since then, you've apparently decided to use www.domain.com and have set up everything else to point to the "www" version. However, your site profile in Analytics still points to the "non-www" version.

 

Log in to Analytics. Click the "Admin" button near the top, on the right. The screen will display a list of accounts (you will probably only have one). Click the name of that account to select it.

 

The screen will display a list of properties (websites) associated with that account (if you only have one website, there may only be that one listed; if you set up more than one website in Analytics, you may have more than one property included in that account). Click the name of the property that's causing the error message to select it.

 

The screen will display a list of all the profiles you've set up that are associated with that property. It's likely there will only be one. Click on that profile to select it.

 

The screen will display the settings for that profile. Click the tab for "Profile Settings". You will see on that tab that the site has been set up for domain.com. Change that to www.domain.com to match what you've set up everywhere else. Make sure your time zone is correct, and if you've specified a default page make sure that is still the correct page name (i.e. "index.html" or "default.asp" or "home.php" or whatever). Click the "Apply" button at the bottom of the page.

 

I honestly don't know how long it will take, but I'm guessing you will probably have to wait until the following calendar day until you see the change fully in effect.

 

If you still need more info, try the Google Analytics Help. (Click the "Help" button right next to the "Admin" button on the orange toolbar at the top.)

 

Hope this helps! :)

 

--Torka :propeller:


  • Alan Perkins likes this

#3 kslnor

kslnor

    HR 2

  • Members
  • PipPip
  • 40 posts
  • Location:USA

Posted 12 February 2013 - 03:08 PM

Torka, thank you so much for the great detail and time spent answering my question.  It worked like a charm and the change occurred within minutes.

 

Appreciate the help greatly !


  • Jill likes this

#4 torka

torka

    Vintage Babe

  • Moderator
  • 4,585 posts
  • Location:Triangle area, NC, USA, Earth (usually)

Posted 13 February 2013 - 10:37 AM

You're very welcome! I'm glad it worked for you, and quicker even than I had originally thought. :)

 

--Torka :propeller:






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

SPAM FREE FORUM!
 
If you are just registering to spam,
don't bother. You will be wasting your
time as your spam will never see the
light of day!