Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google      Sign In   
  • Create Account

Subscribe to HRA Now!

 



Are you a Google Analytics enthusiast?

Share and download Custom Google Analytics Reports, dashboards and advanced segments--for FREE! 

 



 

 www.CustomReportSharing.com 

From the folks who brought you High Rankings!



Photo
- - - - -

Problem In Enabling Wordpress Caching


  • Please log in to reply
3 replies to this topic

#1 T.N

T.N

    HR 4

  • Active Members
  • PipPipPipPip
  • 173 posts

Posted 27 November 2011 - 07:21 AM

Dears,

I'm trying to enable caching for a WordPress website. I tried use the mod_expires on the .htaccess file & it didn't work.

I also tried to use the "WP Super Cache" plugin. I went through some of its settings & the plugin says it works. But when I use Google page speed test it fails and says it still needs the cache to be enabled.

I need help please...

#2 chrishirst

chrishirst

    A not so moderate moderator.

  • Moderator
  • 6,833 posts
  • Location:Blackpool UK

Posted 27 November 2011 - 07:25 AM

Enable caching where? and by what?

#3 T.N

T.N

    HR 4

  • Active Members
  • PipPipPipPip
  • 173 posts

Posted 27 November 2011 - 07:27 AM

QUOTE(chrishirst @ Nov 27 2011, 04:25 PM) View Post
Enable caching where? and by what?

dear chrishirst
I'm trying to enable browser caching for my website. My website is a wordpress website. I follow the steps but it doesn't work.

#4 chrishirst

chrishirst

    A not so moderate moderator.

  • Moderator
  • 6,833 posts
  • Location:Blackpool UK

Posted 27 November 2011 - 08:27 AM

Pages produced from scripts will rarely be cached by browsers because the HTTP Last-Modified header is always set as the time the page was created, simply because it WAS "last modified" at the point in time that it was requested

WP-SuperCache creates static HTML pages which are served out to some users, which, unless your server has a piss-poor CPU or is grossly overloaded will make very little difference to anything important.

If you want to enable browser caching, go into your browser options or preferences and set "Never check for updated version of pages", others of course will have their settings different and may even have it set to check "on each visit" (me for instance) which will of course defeat anything at all that YOU try and do.

YOU cannot force caching by browsers because it will be overridden by the client setting, you can stop it been cached but NOT force it.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

SPAM FREE FORUM!
 
If you are just registering to spam,
don't bother. You will be wasting your
time as your spam will never see the
light of day!