Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google      Sign In   
  • Create Account

Subscribe to HRA Now!

 



Are you a Google Analytics enthusiast?

Share and download Custom Google Analytics Reports, dashboards and advanced segments--for FREE! 

 



 

 www.CustomReportSharing.com 

From the folks who brought you High Rankings!



Photo
- - - - -

Joomla Site Not Showing In Serp's


  • Please log in to reply
9 replies to this topic

#1 Lang

Lang

    HR 2

  • Members
  • PipPip
  • 13 posts

Posted 07 April 2011 - 03:20 PM

I'm working on a Joomla website for a local business that isn't ranking at all for any relevant keyword - including the business name.

The site is only about six months old and has relatively few links. I realize it takes time to compete for even low-volume keywords, but I think something else may be preventing the site from showing up.

The site is not blocked by Robots.txt (which includes a valid reference to the sitemap)
There is no duplicate content issue, the .htaccess is redirecting all non-www traffic to www version
Every page has a unique title and H1 tag.
The URL's are search-engine friendly (not dynamic either)
XML sitemap is live and submitted to Google WM Tools. Google shows that it is indexing about 70% of the submitted URL's.

The site has essentially no domain authority (0.02) according to Moz - I'm assuming this is due to lack of links and short life on the web.
Until today, 98% of the pages has identical meta descriptions.

Again, I realize six months is not an eternity - but the site will not even show up for "business name + city,state" searches in Google. In fact, the only way I've seen it in organic results is to search for the exact URL.

I would greatly appreciate any help.
I haven't posted the URL - not sure if that's proper protocol.

#2 Jill

Jill

    Recovering SEO

  • Admin
  • 33,004 posts

Posted 07 April 2011 - 05:14 PM

Is the business name plus city and state in the Title tag of the home page?

#3 Lang

Lang

    HR 2

  • Members
  • PipPip
  • 13 posts

Posted 08 April 2011 - 08:09 AM

Hi Jill. Yes, the business and the city/state are in the title tag and also the H1 tag.

#4 MauriceWalshe

MauriceWalshe

    HR 2

  • Active Members
  • PipPip
  • 20 posts

Posted 08 April 2011 - 11:27 AM

check that you havnt left joomla in development mode which can block the site

#5 Jill

Jill

    Recovering SEO

  • Admin
  • 33,004 posts

Posted 08 April 2011 - 11:57 AM

Hard to say without giving it a thorough review then. Often it's just a question of a few more links.

#6 Lang

Lang

    HR 2

  • Members
  • PipPip
  • 13 posts

Posted 08 April 2011 - 12:48 PM

Maurice - I'm not seeing anything within Joomla admin that seems to toggle development mode on or off.

#7 Jill

Jill

    Recovering SEO

  • Admin
  • 33,004 posts

Posted 08 April 2011 - 02:28 PM

Lang, I wasn't asking you to give me the site, just thinking that you may want to get professional help for this type of issue rather than just forum help. For site reviews here, we have some pretty stringent rules.

#8 Lang

Lang

    HR 2

  • Members
  • PipPip
  • 13 posts

Posted 08 April 2011 - 02:44 PM

Jill, no problem - my apologies.

This forum is pretty specific to indexing problems - this seemed like as good a place as any to discuss something like this.

#9 qwerty

qwerty

    HR 10

  • Moderator
  • 8,627 posts
  • Location:Somerville, MA

Posted 09 April 2011 - 02:06 PM

Just taking a stab in the dark here... you mentioned robots.txt, but do the individual pages have robots meta tags?

#10 Lang

Lang

    HR 2

  • Members
  • PipPip
  • 13 posts

Posted 12 April 2011 - 01:14 PM

The do, in fact, but they are all set to 'index, follow.'




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

SPAM FREE FORUM!
 
If you are just registering to spam,
don't bother. You will be wasting your
time as your spam will never see the
light of day!