Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google      Sign In   
  • Create Account

Subscribe to HRA Now!

 



Are you a Google Analytics enthusiast?

Share and download Custom Google Analytics Reports, dashboards and advanced segments--for FREE! 

 



 

 www.CustomReportSharing.com 

From the folks who brought you High Rankings!



Photo
- - - - -

/feed Pages In Wordpress Creating Server Error


  • Please log in to reply
4 replies to this topic

#1 poxc2006

poxc2006

    HR 1

  • Members
  • Pip
  • 9 posts

Posted 23 March 2011 - 09:16 AM

I use Wordpress to manage a static site - my company has no intention of using the blog or adding a "news" section or anything like that - too many sites, not enough time. However, when I ran Xenu link sleuth on the site, several pages popped up with server errors - all with URLs ending in "/feed". There are no actual links on the pages, but it does show up in the source code <head> section "<link rel="alternate" type="application/rss+xml" title="Inn At Deep Creek RSS Feed" href="http://innatdeepcreek.com/feed/" /> "

First question is, should I be concerned that Xenu is showing these /feed pages as server errors for SEO purposes?

I figured it couldn't be that complicated to fix this, so I went into the Wordpress forums and found some PHP code that when inserted into functions.php, it makes those pages display "no feed available - please visit our homepage" with a link. I assumed this would be better than a 404 error.

However, Xenu still shows up as "sever error". Anybody know how to fix this? Or should I even be concerned about this for SEO purposes?



#2 Jill

Jill

    Recovering SEO

  • Admin
  • 32,928 posts

Posted 23 March 2011 - 09:47 AM

Why don't you just remove that feed line in your WP template if you're not actually going to have a feed? Either that or create a feed. Usually WP does that automatically.

#3 poxc2006

poxc2006

    HR 1

  • Members
  • Pip
  • 9 posts

Posted 23 March 2011 - 10:14 AM

QUOTE(Jill @ Mar 23 2011, 10:47 AM) View Post
Why don't you just remove that feed line in your WP template if you're not actually going to have a feed? Either that or create a feed. Usually WP does that automatically.


If you know how to edit it from within wp-admin, please let me know. I looked in all the documentation I could find and searched on wordpress.org forums and forums for Thesis (theme I use), all I could find was that you cannot turn off the feed from within wp-admin; you have to add code to functions.php. Which I did, but still generating a server error in Xenu.


#4 cfreek

cfreek

    AAAHHHH!!1one1!

  • Active Members
  • PipPipPipPip
  • 166 posts
  • Location:Richmond, Virginia, Earth

Posted 23 March 2011 - 11:37 AM

Trying one of the URLs from your screenshot in a HTTP header checked, the code you added is returning a 500 Internal Server Error.

I'm assuming you added this code:
tools.devshed.com/c/a/Blog-Help/WordPress-CMS-Tips-Removing-RSS-Feeds/2/
Which this site mentions that the 500 error will happen.



#5 poxc2006

poxc2006

    HR 1

  • Members
  • Pip
  • 9 posts

Posted 24 March 2011 - 08:18 AM

QUOTE(cfreek @ Mar 23 2011, 12:37 PM) View Post
Trying one of the URLs from your screenshot in a HTTP header checked, the code you added is returning a 500 Internal Server Error.

I'm assuming you added this code:
tools.devshed.com/c/a/Blog-Help/WordPress-CMS-Tips-Removing-RSS-Feeds/2/
Which this site mentions that the 500 error will happen.


Wow, I feel stupid. Thank you. I didn't see the server error part at the bottom.

Now I see there is a 301 redirect solution with htacess. I'll try that instead.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

SPAM FREE FORUM!
 
If you are just registering to spam,
don't bother. You will be wasting your
time as your spam will never see the
light of day!