Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google      Sign In   
  • Create Account

Subscribe to HRA Now!

 



Are you a Google Analytics enthusiast?

Share and download Custom Google Analytics Reports, dashboards and advanced segments--for FREE! 

 



 

 www.CustomReportSharing.com 

From the folks who brought you High Rankings!



Photo
- - - - -

Have I Screwed Up My Seo Related Tages? =/


  • Please log in to reply
2 replies to this topic

#1 Seamless

Seamless

    HR 1

  • Members
  • Pip
  • 1 posts

Posted 24 October 2010 - 02:05 AM

Hi guys and girls,

Hoping someone can help me out as I'm a bit stuck with the whole SEO thing... =/

Currently the bit just under my <head> tag says this:


CODE
<meta name="google-site-verification" content="01020201031203021031203120301230" />
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<title>Credit-Credit | Nationwide Debt Recovery</title>
<meta name="title" content="Debt Collection, Debt Recovery, Debt Collection Bristol, Debt Collection Weston Super Mare, Debt Recovery Weston Super Mare, Debt Recovery Bristol"/>
<meta name="description" content="Nationwide Debt Recovery & Debt Collection specialists based near Bristol. Don't give up on overdue invoices, get paid no win no fee."/>
<meta name="keywords" content="Debt Collection, Debt Recovery, Debt Collection Bristol, Debt Collection Weston Super Mare, Debt Recovery Weston Super Mare, Debt Recovery Bristol"/>



However when I run SEO Analyser tools they come up with error and google webmaster tools says 'No Data' so I think I must have done something wrong... I am a bit confused with the title, description and keywords... I think I have got mixed up somewhere. My own fault for playing around with all the wordpress plugins I guess =/

#2 piskie

piskie

    HR 7

  • Active Members
  • PipPipPipPipPipPipPip
  • 1,098 posts
  • Location:Cornwall

Posted 24 October 2010 - 04:27 AM

First thing I notice is <meta name="title" ........
That is an unnecessary tag (unless needed for local site search function) that does nothing and in any case is only a duplicate of the contents in your Keywords tag.

The second thing I noticed is many of your tags don't have a space preceding the closing slash. The only one that does is the Verification one that Google gave you.

The third thing I noticed is that you don't have a closing slash following utf-8"

#3 qwerty

qwerty

    HR 10

  • Moderator
  • 8,547 posts
  • Location:Somerville, MA

Posted 24 October 2010 - 08:43 AM

What document type declaration are you using? And we know you have an opening <head> tag, but do you also have <html> above it, right below the DTD, </head> to close the head, followed immediately by <body> to open the body and </body> at end, just before the closing </html>?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

SPAM FREE FORUM!
 
If you are just registering to spam,
don't bother. You will be wasting your
time as your spam will never see the
light of day!