Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google      Sign In   
  • Create Account

Subscribe to HRA Now!

 



Are you a Google Analytics enthusiast?

Share and download Custom Google Analytics Reports, dashboards and advanced segments--for FREE! 

 



 

 www.CustomReportSharing.com 

From the folks who brought you High Rankings!



Photo

Wordpress / Rss Plugin Crashed My Server!


  • Please log in to reply
3 replies to this topic

#1 Andy1342

Andy1342

    HR 3

  • Active Members
  • PipPipPip
  • 74 posts

Posted 09 January 2010 - 07:29 PM

I am setting up a new Wordpress blog as part of my website. I am struggling to place a "subscribe to RSS feed" button on the blog - I'm new to this, finding stuff out as I go along.

Anyway, I tried a plugin called "add-to-Any", which didn't work. So I uploaded the Feedburner plugin. I placed it in the plugins directory. For some reason it didn't show up in the installed plugins list in the Wordpress dashboard, so I never got to activate it. But, within a minute of uploading it, my ENTIRE site went 404 not found and I had an email from my hosts saying that my site has been using up to 50% of the server, and they have taken me off the air! Spectacular for one little plugin!

I guess I can get my site back easily enough, by deleting Wordpress if I have to. But I am starting to really hate Wordpress.

Several questions:
(1) What the heck is going on?! Has this happened to anyone else? Could it be anything other than the Feedburner plugin?
(2) What simple, straightforward RSS plugin should I use to let people subscribe to my site, compatible with Wordress 2.9?
(3) This may or may not be relevant. At the bottom of my front page are two links saying something like "RSS entries" and "RSS comments". When I click on these I get two completely blank white pages, although the blog does have a handful of test entries and comments. Is this correct? I don't understand what these links are, but it seems odd that that are 100% blank. Could this be a reason why none of the subscription plugins I use works?

Pardon my ignorance if any of these are dumb questions - I am dumb on all this, as yet.

Many thanks for any thoughts!

Regards

Andy

#2 Randy

Randy

    Convert Me!

  • Moderator
  • 17,540 posts

Posted 09 January 2010 - 11:39 PM

It sounds like something simply went terribly wrong with the RSS plugin Andy. I've not heard of anybody else reporting a similar problem with that particular plugin, or with any of the available WP RSS plugins for that matter.

For it to spike CPU Load like that means something somewhere got caught in one heck of a loop.

How were you installing the plugin? Did you use the automated thingee where you allow your WP blog itself to download the plugin right to your server? If so, you may want to try manually downloading it and then FTP'ing it to your site yourself. I do that as a normal course since I don't want to run the risk of sending my FTP username and password across the web to WPs plugin installer.

#3 Jill

Jill

    Recovering SEO

  • Admin
  • 32,956 posts

Posted 10 January 2010 - 10:15 AM

As I mentioned in your other thread, have you thought about hiring someone to get things set up for you?

Free things will take a certain amount of knowledge and skills, just like anything else.

Also, as far as the RSS feed goes, it's been my experience that is there by default when you install.

#4 qwerty

qwerty

    HR 10

  • Moderator
  • 8,619 posts
  • Location:Somerville, MA

Posted 10 January 2010 - 01:51 PM

Jill's right that you should already have RSS enabled by default. If you look in the source code of every page of the blog, you should see something like this in the <head>:
HTML
<link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="http://www.domain.com/feed/" />
<link rel="alternate" type="text/xml" title="RSS .92" href="http://www.domain.com/feed/rss/" />
<link rel="alternate" type="application/atom+xml" title="Atom 0.3" href="http://www.domain.com/feed/atom/" />

All the feedburner plugin does is set up redirects from all of those feeds to the Feedburner feed, which is located at a URL like feeds.feedburner.com/NameOfSite.

Assuming the blog is generating the default feeds, you don't really have to do anything. Most browsers will detect the feed and that RSS icon will be visible to users. If you want to add the icon to your pages, you can just edit your page template to include it (or there's probably a WP widget that you can use to include it) and link it to one of the feeds.

If you're going to redirect all requests for an RSS feed to the Feedburner feed, the first thing you have to do is set up a Feedburner feed. Is it possible you set up the redirects to a feed that doesn't yet exist? I doubt that would cause the server to get stuck in some infinite loop, but it's the first thing I'd check: the feed has been set up, and you're pointing to its correct URL.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

SPAM FREE FORUM!
 
If you are just registering to spam,
don't bother. You will be wasting your
time as your spam will never see the
light of day!