Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google      Sign In   
  • Create Account

Subscribe to HRA Now!

 



Are you a Google Analytics enthusiast?

Share and download Custom Google Analytics Reports, dashboards and advanced segments--for FREE! 

 



 

 www.CustomReportSharing.com 

From the folks who brought you High Rankings!



Photo
- - - - -

Site Ranking For Top Keywords But Not Indexed By Google. Is It A Fault


  • Please log in to reply
4 replies to this topic

#1 sofomor

sofomor

    HR 2

  • Members
  • PipPip
  • 10 posts

Posted 01 June 2009 - 07:28 AM

Google webmaster console says "No pages from your site are currently included in Google's index. Indexing can take time.....blah..blah" but the pages from the site are ranking for almost all of our targeted keywords. Is it a fault or am I missing something?

The site needs to be indexed before its ranked and not the other way round.

Urgent answers please with elaboration.

Regards

#2 Randy

Randy

    Convert Me!

  • Moderator
  • 17,540 posts

Posted 01 June 2009 - 07:40 AM

Sounds like a Webmaster Tools glitch to me.

If you can see your pages are indexed in Google and actually ranking, it's pretty obvious WMT's is messing up, correct?

#3 sofomor

sofomor

    HR 2

  • Members
  • PipPip
  • 10 posts

Posted 08 June 2009 - 06:38 AM

QUOTE(Randy @ Jun 1 2009, 07:40 AM) View Post
Sounds like a Webmaster Tools glitch to me.

If you can see your pages are indexed in Google and actually ranking, it's pretty obvious WMT's is messing up, correct?


Thanks Randy.

Google cache is fine and URLs are ranking as well. Checked robotx.txt, noindex thingy and stuff but its all fine. WMT is working fine for other sites. May be a glitch.

What say others?


#4 Jill

Jill

    Recovering SEO

  • Admin
  • 32,929 posts

Posted 08 June 2009 - 08:09 AM

Sounds like you should stop using WMT since everything is fine otherwise.

#5 Bri

Bri

    HR 4

  • Active Members
  • PipPipPipPip
  • 207 posts
  • Location:Toronto, Ontario

Posted 08 June 2009 - 08:38 AM

I have found WMT to be very glitchy, nearly sent me around the twist!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

SPAM FREE FORUM!
 
If you are just registering to spam,
don't bother. You will be wasting your
time as your spam will never see the
light of day!