Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google      Sign In   
  • Create Account

Subscribe to HRA Now!

 



Are you a Google Analytics enthusiast?

Share and download Custom Google Analytics Reports, dashboards and advanced segments--for FREE! 

 



 

 www.CustomReportSharing.com 

From the folks who brought you High Rankings!



Photo
- - - - -

Throwing Up A Redirect Loop


  • Please log in to reply
5 replies to this topic

#1 WesMcDermott

WesMcDermott

    HR 2

  • Members
  • PipPip
  • 42 posts
  • Location:Manchester, UK

Posted 13 March 2009 - 12:21 PM

Hey,

When I'm trying to access the wordpress blog which is in a sub folder here www.nipponautomotive.co.uk/blog/ firefox returns a redirect loop, the redirections limit for the url have exceeded response. I've looked around and it seems as though a lot of people are having similar issues. I'm unsure as to what this might be, any ideas anyone?

#2 Jill

Jill

    Recovering SEO

  • Admin
  • 33,244 posts

Posted 13 March 2009 - 12:28 PM

There are some clues when you check it via Randy's header checker tool: http://www.randycull...aderchecker.php

#3 Randy

Randy

    Convert Me!

  • Moderator
  • 17,540 posts

Posted 13 March 2009 - 12:38 PM

Looks like it's redirecting back onto itself Wes. So can never complete.

There's probably something in the .htaccess that is redirecting the index file via %{REQUEST_URL} instead of using %{THE_REQUEST}. But I'd have to see the .htaccess to tell ya for sure.

#4 WesMcDermott

WesMcDermott

    HR 2

  • Members
  • PipPip
  • 42 posts
  • Location:Manchester, UK

Posted 15 March 2009 - 03:28 PM

Thanks for your input guys.

I've checked the .htaccess for the site and there's no mention %{REQUEST_URL}. I've checked the header tool you suggested and it's coming back with :
CODE
HTTP/1.1 301
Date: Sun, 15 Mar 2009 20:20:25 GMT
Server: Apache/1.3.41 (Unix) mod_log_bytes/1.2 mod_bwlimited/1.4 mod_auth_passthrough/1.8 FrontPage/5.0.2.2635 mod_ssl/2.8.31 OpenSSL/0.9.7a
X-Pingback: http://nipponautomotive.co.uk/blog/xmlrpc.php
X-Powered-By: PHP/4.4.9
Location: http://nipponautomotive.co.uk/blog/
Connection: close
Content-Type: text/html; charset=UTF-8


So it is returning a 301 redirect. One thing stands out though, the X-pingback whatever that is, could it be a problem with this file? Stumped once again :-) Randy you must be getting a bit sick of me by now :-)

#5 Randy

Randy

    Convert Me!

  • Moderator
  • 17,540 posts

Posted 15 March 2009 - 04:44 PM

Nah, not at all Wes. I like this kind of geeky stuff. giggle.gif

The pingback shouldn't have any effect.

You don' t have any sort of scripted redirect set up on your index page do you?

If you want to PM over your .htaccess I'll see if I can spot the problem. It's usually some simple, harmless looking typo in my experience.

#6 WesMcDermott

WesMcDermott

    HR 2

  • Members
  • PipPip
  • 42 posts
  • Location:Manchester, UK

Posted 15 March 2009 - 05:05 PM

QUOTE(Randy @ Mar 15 2009, 09:44 PM) View Post
Nah, not at all Wes. I like this kind of geeky stuff. giggle.gif

The pingback shouldn't have any effect.

You don' t have any sort of scripted redirect set up on your index page do you?

If you want to PM over your .htaccess I'll see if I can spot the problem. It's usually some simple, harmless looking typo in my experience.


Erm, I'm not sure Randy. I will send the .htaccess through then. crossfingers.gif




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

We are now a read-only forum.
 
No new posts or registrations allowed.